New Feature: Facebook Connect

You can now sign-in with your Facebook account, in order to post on You should see a blue "Connect with Facebook" logo above the reply form (as long as you are not already signed in). Clicking that link will pop-up a Facebook login form, making it easy for you to login. You will then be able to post replies. Note that your Facebook password is never sent, shared, or stored with this site -- you are logging on directly to

Using Facebook Connect on this site is completely optional, but I encourage you to at least give it a try. One of the benefits of signing in, (as with Typekey and other future sign-in options), is that you will bypass many of the spam filters when posting. While the spam filters are designed to only block spam advertising, sometimes legit posts get blocked in error -- signing in can help avoid these rare but frustrating occurrences.

Another feature of using Facebook Connect, is that you can (optionally) share your Mars Rover Blog posts with your Facebook friends. When signed in via Facebook, you will see a popup giving you the option to share your post on your Facebook page. If you don't want to do this, hit the "No, Thanks" button. Note that there is also a "Always do this for Mars Rover Blog" checkbox -- note that this works both ways, either always share on Facebook or *always* No, Thanks -- so you can use this checkbox to prevent the popup for future posts, whatever your preferred option may be.

As always, your feedback is appreciated. Please reply here if you have any issues, or if you have any suggestions for improvements.

Tried to post a topic of Phoenix geology and Phoenix closeup, but I was entangled with the newest Horton topic posting which was nearly simultaneous apparently. I received the Horton topic image and text as a substitute for my information. My topic appears to have disappeared or been held once again. Do you have the topic info, or is there a delay or denial?
I will register at Facebook and try the process. I have a registration for most of the social Web sites, but I am not active at those. Thanks. Dana, 2:50PM, Tuesday.

I eliminated the two cookies specifically referencing, and typepad,
and found my mistaken entry for the prior posting attempt was placed on the Horton topic, where it can remain without damage, I believe.
Attempting to establish the entry as a separate topic on the 'Mars Geology' section before registering at Facebook has not worked, now, with an error page new to my memory, stating "cannot locate object method 'preview' via "MT:APP:MTForumPost"". in the mt-forumpost.cgi .
I'll try to register at Facebook and save the topic content for a second try later if necessary. A text entry was successful on an established topic.
My early mistake must have been a mis-key to the 'new reply' rather than the 'new topic' button as they are the same color and size.